Unspecified error IOException

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Unspecified error IOException

flom
Hello everyone

I've got some problems and maybe someone can help me.
I need the streets from  brandenburg germany for routing. cars only.

first of all
I am using:
arcgis 10.2.1
Java 7.0.60
osm2nds_console_1.1.1.jar
Parameters_Motorcar_v1.1.xml


I've got my osm file from geofabrik. Converted the osm file with osmconvert with a poly file.
Afterwards I used osmosis to get only the necessary streets to slim down my osm file.
So far so good. Everything works so far.
But while creating the mxd file, after 8,5 hrs and 88% process the error
ERROR: AutomationException: Unspecified error IOException: Therefore the process is canceled.
comes up.

The error message isn't really specific. What happens there??? or is that a problem with the new gis version?????

The other warnings in the log files would be my secondary question. I know why but i don't know how to avoid it.

thanks a lot for any help
if someone need any other information let me know

here some files
LOGFILENAME.log
batch_osm2nds2.bat
osmosis.bat
Reply | Threaded
Open this post in threaded view
|

Re: Unspecified error IOException

peterseva
Hi!

According to your log file the following steps were executed successfully:

5% finished: Parameters successfully read.
11% finished: OSM data successfully read.
16% finished: Workspace successfully generated.
22% finished: Spatial reference successfully generated.
27% finished: Feature dataset successfully generated.
33% finished: Empty feature class barriers successfully written.
38% finished: Network dataset successfully written.
44% finished: Empty turn feature class turns successfully written.
50% finished: Network dataset attribute 'Turn Restriction' successfully added.
55% finished: Turn restrictions successfully generated.
61% finished: OSM ways successfully added.
66% finished: OSM relations successfully added.
72% finished: OSM nodes successfully added.
77% finished: Map document successfully created.
83% finished: Data layers successfully added to the map document.
88% finished: Network analysis layers successfully added to the map document.

Your application stopped before the following two steps:

94% finished: Network successfully rebuilt.
100% finished: Map document successfully saved.

I don't know why the application stopped while rebuilding the network. The ArcGIS version 10.2.1 should work.

Please, try to rebuild your network "manually". Does it work?
Can you open your map document? Does it contain all layers?

The warnings are explained in the following thread:
http://osm2nds.forum.52north.org/Error-and-warning-messages-td4639567.html

Are there any (other) warnings/error I should explain?

Best wishes,
Eva


Reply | Threaded
Open this post in threaded view
|

Re: Unspecified error IOException

flom
i tried to build the network manually.
there where no error messages but the network is not working correctly
if i wanna calculate  a new service area the result looks like this

Screenshot1.png
Screenshot2.png


i have no clue why it is not working.
can you tell me something about how osm2nds is creating the network?
maybe i forgot something or did something wrong
thanks

flom


Reply | Threaded
Open this post in threaded view
|

Re: Unspecified error IOException

peterseva
Hi!

This network looks really strange! Could you please send

the original OSM data,
the adapted OSM data,
the parameters file,
and the calculated network?

Then, I will have a look at this.

Best wishes,
Eva
Reply | Threaded
Open this post in threaded view
|

Re: Unspecified error IOException

flom
thanks for your help
 i managed to upload the file

files
the original dadaset are from geofabrik brandenburg file
bb